DematVr Forum
https://www.lampschool.it:80/phpbb/

Coordinatore di classe NON carica documenti
https://www.lampschool.it:80/phpbb/viewtopic.php?f=4&t=12957
Pagina 1 di 1

Autore:  andrea [ 24/10/2018, 17:55 ]
Oggetto del messaggio:  Coordinatore di classe NON carica documenti

Salve.
Il coordinatore di classe NON riesce a caricare i documenti della classe (PDF). Va in funzione coordinatore, sceglie che tipo di documento caricare, mette il nome.... sfoglia.... sceglie file...
INVIA file selezionato ma... NON viene caricato nulla...

Funziona invece la "funzione" carica documenti dei docenti (nelle loro materie)...
Aiuto!!
qualche problema in "documenticlasse.php"?

noi usiamo salvataggio in HD

Autore:  walter [ 30/10/2018, 15:27 ]
Oggetto del messaggio:  Re: Coordinatore di classe NON carica documenti

Noi riscontriamo lo stesso problema, non vengono caricati i documenti di classe.
Aggiungo che funziona tutto bene invece con i documenti dei singoli alunni, che vengono caricati senza problemi.

Grazie

Autore:  walter [ 02/11/2018, 11:58 ]
Oggetto del messaggio:  Re: Coordinatore di classe NON carica documenti

Ho verificato che in realtà i documenti vengono caricati, tutti i dati vengono correttamente registrati nel database e se un documento viene richiamato tramite browser con la funzione di visualizzazione dei documenti (/documenti/actionsdocum.php?action=view&Id=)
si vede perfettamente.
Il problema è che nella pagina dei documenti di classe non si genera la tabella con l'elenco dei documenti caricati.
Io non ho molta competenza con il linguaggio php e sto andando per tentativi, sperando di capire qual è il disguido.

Autore:  paolo_rag [ 08/11/2018, 19:06 ]
Oggetto del messaggio:  Re: Coordinatore di classe NON carica documenti

Avrei risolto così:
dato che nella versione 2017 tutto funzionava, ho confrontato i file documenticlasse.php che sono risultati identici (quindi il problema non era lì); allora ho confrontato le tabelle del db a cui fa riferimento il file, tbl_documenti e tbl_tipidocumenti e ho notato che i valori "NULL" e "PREDEFINITO" di quasi tutti i campi erano differenti (vedi figura). Modificati i valori (NULL=NO e PREDEFINITO=NESSUNO) tutto sembra funzionare.
Non so se la cosa sia ortodossa però funziona.
Anche nella tabella tbl_tipidocumenti un campo (descrizione) differisce nello stesso modo, ma dato che funziona non l'ho modificato.

Allegati:
tabelle.png
tabelle.png [ 229.17 KiB | Osservato 521 volte ]

Autore:  andrea [ 09/11/2018, 15:16 ]
Oggetto del messaggio:  Re: Coordinatore di classe NON carica documenti

perfetto.... fatte le modifiche ed ora tutto OK
Si vedono i documenti caricati

Autore:  walter [ 09/11/2018, 21:19 ]
Oggetto del messaggio:  Re: Coordinatore di classe NON carica documenti

Ho fatto anch'io le modifiche suggerite e ora funziona tutto.
Grazie mille!

Pagina 1 di 1 Tutti gli orari sono UTC [ ora legale ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/