DematVr Forum
https://www.lampschool.it:80/phpbb/

Perchè la versione 2015.0.1
https://www.lampschool.it:80/phpbb/viewtopic.php?f=15&t=12549
Pagina 1 di 2

Autore:  scaforchio [ 04/12/2015, 9:01 ]
Oggetto del messaggio:  Perchè la versione 2015.0.1

La versione 2015.0.1 è una versione rilasciata 'in corsa' in attesa della 2015.1 prevista per Gennaio.
Si è deciso di rilasciare comunque questa versione perché alcune funzionalità aggiuntive e precauzioni di sicurezza sono state sollecitate da alcune scuole e si è deciso di rilasciare comunque questa versione interlocutoria.
Alcune delle funzionalità previste per la 2015.1 sono già presenti in questa versione, altre, ancora in fase di sviluppo o test saranno aggiunte solo con la 2015.1

Per questioni di sicurezza è stato cambiato il nome del file di log e, dopo l'aggiornamento, il log precedente non sarà più visualizzabile con l'apposita funzione prevista lato admin. Esso è comunque presente ed è scaricabile tramite ftp. Se ne consiglia vivamente la rimozione o la sua ridenominazione subito dopo l'aggiornamento.

Un'altra funzione aggiunta ma non immediatamente 'visibile' è la possibilità di lanciare l'invio degli SMS per le assenze in automatico ad un'ora prefissata. Se c'è qualcuno che è interessato può contattarmi in privato per la spiegazione di come attivare la funzionalità.

Un ultimo avviso per i pigri che non leggono il file install.txt: chi deve aggiornare l'attuale versione NON deve copiare sul server la cartella /abc

La procedura di aggiornamento effettuerà in automatico l'avanzamento di versione per tutte le installazioni multiple eventualmente presenti.

Chi vuole aggiornare senza eseguire la procedura automatica può procedere come segue:

1 - aprire il file /install/sql/update/2015.0.1.sql e copiarne il contenuto;
2 - entrare nella propria installazione come amministratore ed entrare nella funzionalità di esecuzione SQL;
3 - incollare i comandi sql precedentemente copiati ed esguire;
4 - uscire e copiare tutti i file nella cartella sul server (eccetto /abc).

I punti dall'1 al 3 dovranno essere eseguiti, in caso di installazione multipla, per ogni installazione presente.

IMPORTANTE: non ci stancheremo mai di ricordare che la legge di Murphy è sempre in agguato quindi procedere sempre con backup di dati e programma prima di procedere.

IMPORTANTISSIMO: quando si trasferiscono i nuovi file sul server NON cancellare le vecchie cartelle ma SOVRASCRIVERLE.

Autore:  coloniasangiuseppe [ 04/12/2015, 12:22 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

NOTE PER L'AGGIORNAMENTO

Per l'aggiornamento si dovrà trasferire sul server (LA DOMANDA E' IN QUALE CARTELLA? /INSTALL?) l'intero contenuto del file zip di installazione AD ECCEZIONE DELLA CARTELLA /abc

Per l'aggiornamento si dovrà accedere sempre alla cartella /install:

http://www.miodominio.it/registro_2014_2015/install/

L'aggiornamento verrà effettuato in automatico su tutti gli ambienti

Autore:  coloniasangiuseppe [ 04/12/2015, 12:24 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

MI RENDO CONTO CHE INSTALL NON ESISTE: FORSE DEVO SOVRASCRIVERE TUTTE LE CARTELLE E POI ACCEDERE IN WEB AD INSTALL

Autore:  denis [ 04/12/2015, 15:36 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

Buongiorno,
chiedo scusa ma non mi è chiaro come effettuare l'aggiornamento nel modo meno indolore possibile...
esiste una procedura automatica?
Devo caricare i file sul server e rifare l'installazione (ma perdo i dati?)
Devo sovrascrivere solamente determinate cartelle?

grazie per l'aiuto

Denis

Autore:  scaforchio [ 04/12/2015, 18:35 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

La procedura è descritta nel file install.txt
Bisogna ( dopo gli opportuni backup) sovrascrivere tutte le cartelle attualmente in uso ( ad eccezione di /abc) ed accedere alla cartella /install da browser. Il sistema riconoscerà che si tratta di un aggiornamento ed effettuerà le operazioni necessarie.
Ovviamente non si perde nessun dato.

Autore:  coloniasangiuseppe [ 05/12/2015, 0:00 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

Scusate l'ignoranza: potreste spiegare in maniera più semplificata (cosa e dove cancellare) il fatto del log?

Autore:  scaforchio [ 05/12/2015, 11:29 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

coloniasangiuseppe ha scritto:
> Scusate l'ignoranza: potreste spiegare in maniera più semplificata (cosa e
> dove cancellare) il fatto del log?

Nella cartella /lampschooldata (o nelle sue sottocartelle nel caso di installazioni multiple) è presente un file (logsql.log) che contiene il file di log. Con l'aggiornamento questo file non verrà più utilizzato ma sarà creato un nuovo file con una denominazione diversa per ogni installazione. Tramite ftp è opportuno cambiare il nome del file non più utilizzato (logsql.log) oppure scaricarlo per conservarlo in locale e cancellarlo dal server.

Autore:  scaforchio [ 05/12/2015, 11:31 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

coloniasangiuseppe ha scritto:
> MI RENDO CONTO CHE INSTALL NON ESISTE: FORSE DEVO SOVRASCRIVERE TUTTE LE
> CARTELLE E POI ACCEDERE IN WEB AD INSTALL

La cartella install va eliminata subito dopo l'installazione (o aggiornamento), ecco perchè non esiste, andando caricare i file della nuova versione essa verrà ricreata. Ricordarsi però di cancellarla dopo l'aggiornamento.

Autore:  salvatore [ 10/12/2015, 12:06 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

Vedo il file logsql.log via ftp e riporta l'ora di qualche minuto prima che effettuassi l'aggiornamento alla 2015.0.1. Posso procedere a rinominarlo (tipo 'oldlogsql')? Chiedo scusa se chiedo conferma ma meglio essere sicuri.
Grazie
Salvatore

Autore:  scaforchio [ 10/12/2015, 12:42 ]
Oggetto del messaggio:  Re: Perchè la versione 2015.0.1

Tranquillo. Puoi rinominare il file logsql.log in qualsiasi momento. Magari non usare un nome banale che potrebbe essere facilmente individuato.

Pagina 1 di 2 Tutti gli orari sono UTC [ ora legale ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/