DematVr Forum

Forum dedicato allo sviluppo del software Lampschool
Oggi è 05/06/2020, 8:53

Tutti gli orari sono UTC [ ora legale ]




Apri un nuovo argomento Rispondi all’argomento  [ 5 messaggi ] 
Autore Messaggio
MessaggioInviato: 26/09/2015, 17:27 

Iscritto il: 08/09/2014, 21:53
Messaggi: 51
quando si prova ad inserire i voti ad un gruppo di alunni e si salva la lezione mi compare il seguente messaggio:

Aggiornamento effettuato!
Errore: select idlezione from 2015_16_tbl_lezioni where idlezionegruppo=114 and idclasse=

Nel richiamare la lezione appena salvata alcuni voti non risultano registrati. Ho provato a reinserirli ma ottengo sempre lo stesso messaggio di errore e i voti continuano a scomparire :o .
Come posso risolvere il problema?
grazie


Top
 Profilo  
 
MessaggioInviato: 26/09/2015, 17:49 

Iscritto il: 19/09/2013, 13:26
Messaggi: 1360
Località: San Giovanni Rotondo
Dovresti darmi qualche informazione in più per provare a riprodurre il problema:
- come è costituito il gruppo? (sottoinsieme di alunni di una classe, alunni di più classi);
- nel secondo caso: i voti che scompaiono sono quelli di una sola classe, di tutte le classi o di una parte delle classi?

_________________
Pietro


Top
 Profilo  
 
MessaggioInviato: 26/09/2015, 22:05 

Iscritto il: 08/09/2014, 21:53
Messaggi: 51
Il gruppo riguarda l'accorpamento di due classi.
I voti "scompaiono" solo ad alcuni alunni di una sola delle classi.
Inoltre mi sono accorto che se richiamo da "Inserimento e modifica" la classe incriminata due alunni, che nel registro si trovano in posizione n.5 e n.6 sono riportati in prima posizione. Se inserisco i voti, in tale modalità di modifica lezione, essi vengono registrati normalmente senza far apparire il messaggio di errore.
Anche nell'altra classe due alunni non sono riportati nella corretta posizione d'ordine ma, in questo caso, compaiono alla fine dell'elenco e i voti sono stati riportati correttamente :?:


Top
 Profilo  
 
MessaggioInviato: 27/09/2015, 11:19 

Iscritto il: 19/09/2013, 13:26
Messaggi: 1360
Località: San Giovanni Rotondo
La situazione si fa sempre più "interessante".
Ti invio per MP il mio indirizzo.
Se mi invii un backup del database indicandomi come riprodurre il problema faccio un'analisi della cosa.

_________________
Pietro


Top
 Profilo  
 
MessaggioInviato: 29/09/2015, 9:10 

Iscritto il: 19/09/2013, 13:26
Messaggi: 1360
Località: San Giovanni Rotondo
Per l'ordinamento vedi patch:

viewtopic.php?f=14&t=12376&start=20#p18757

Per il mancato inserimento, risultava nel gruppo un alunno non più presente nell'anagrafica.

_________________
Pietro


Top
 Profilo  
 
Visualizza ultimi messaggi:  Ordina per  
Apri un nuovo argomento Rispondi all’argomento  [ 5 messaggi ] 

Tutti gli orari sono UTC [ ora legale ]


Non puoi aprire nuovi argomenti
Non puoi rispondere negli argomenti
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi inviare allegati

Vai a:  
cron
Powered by phpBB® Forum Software © phpBB Group
Traduzione Italiana phpBBItalia.net basata su phpBB.it 2010